Billy AI Assistant is down.

Incident Report for Finout

Postmortem

We’ve recently refactored our internal API’s to have a more consistent signature.

One of the old API signatures was used internally by Billy’s server and was not tested properly.
Billy Service relies on that API to validate he is authorized to work on the account and since the API call failed, it returned an unauthorized response which resulted in a UI failure.

The issue has been rectified and New E2E tests and manual test plans are being written.

Posted May 18, 2026 - 15:04 UTC

Resolved

Billy, Finout's AI chat Assistant was down for 30 minutes.
Posted May 18, 2026 - 14:00 UTC